× Help us help you. By posting the year, make, model and engine near the beginning of your help request, followed by the symptoms (no start, high idle, misfire etc.) Along with any prevalent Diagnostic Trouble Codes, aka DTCs, other forum members will be able to help you get to a solution more quickly and easily!

Subaru Impreza 2003

  • scotty.sutherland
  • scotty.sutherland's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
25 Nov 2019 04:00 - 25 Nov 2019 04:05 #35293 by scotty.sutherland
Subaru Impreza 2003 was created by scotty.sutherland
Hi all New to forum :lol: was advised to use forum by paul :)
I have a 2003 subaru impreza wrx only has induction kit everything else is standard/stock it was recently rebuilt with closed deck shortblock, been having problems main one being the car will not idle with maf in... just idle hunts so low it stalls, but will run and idle fine with maf out, i tried a diff maf (wasnt new) and it did the exact same thing? Replaced intake manifold gaskets and checked for leaks did compression test, checked coils/plug gaps etc, there is also no error codes wen its idling low/stalling.
The other weird problem is my head unit is toast as its getting power and solid ground, But.... the rear of my car chassis is not grounded so my amps couldnt possibly work now as there grounded in boot!? but the front of chassis is showing ground lol the ground thing sounds impossible to me lol makes me think somethings bad with wiring/ground and its all related

Any help would be great! :)
Last edit: 25 Nov 2019 04:05 by scotty.sutherland.

Please Log in or Create an account to join the conversation.

  • Noah
  • Noah's Avatar
  • Offline
  • Moderator
  • Moderator
  • Massachusetts, USA
More
25 Nov 2019 06:53 #35294 by Noah
Replied by Noah on topic Subaru Impreza 2003
Do you still have the stock air filter plumbing? If so I'd pop it back it in and see if the problem goes away.
Sometimes those "power adders" are problem makers.

"Learn, apply, repeat."
The following user(s) said Thank You: scotty.sutherland

Please Log in or Create an account to join the conversation.

  • scotty.sutherland
  • scotty.sutherland's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
25 Nov 2019 06:56 #35295 by scotty.sutherland
Replied by scotty.sutherland on topic Subaru Impreza 2003
i do yes, just left the cone filter on as it was there from the old block etc :) ill do tht and get bk to you mate, thanks
The following user(s) said Thank You: Noah

Please Log in or Create an account to join the conversation.

  • scotty.sutherland
  • scotty.sutherland's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
25 Nov 2019 13:11 #35303 by scotty.sutherland
Replied by scotty.sutherland on topic Subaru Impreza 2003
ok i took the induction off and put stock airbox on disconected the batt etc .... started to idle nice, revved bit higher then got engine management light pop up (idle died way down as soon as light popped up) got... p1500 unknown code

Please Log in or Create an account to join the conversation.

  • scotty.sutherland
  • scotty.sutherland's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
25 Nov 2019 13:14 #35304 by scotty.sutherland
Replied by scotty.sutherland on topic Subaru Impreza 2003
P1500 SUBARU - Radiator Fan Relay 1 Circuit Malfunction

Please Log in or Create an account to join the conversation.

  • Noah
  • Noah's Avatar
  • Offline
  • Moderator
  • Moderator
  • Massachusetts, USA
More
25 Nov 2019 13:22 #35305 by Noah
Replied by Noah on topic Subaru Impreza 2003
So better or not better?
(Minus the fan code)

"Learn, apply, repeat."
The following user(s) said Thank You: scotty.sutherland

Please Log in or Create an account to join the conversation.

  • scotty.sutherland
  • scotty.sutherland's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
25 Nov 2019 13:25 - 25 Nov 2019 13:27 #35306 by scotty.sutherland
Replied by scotty.sutherland on topic Subaru Impreza 2003
much better idle is fine didnt go revving it ...then it will idle high n throw tht code ;)

** engine was warm when i put the stock filter bk on, not sure if tht makes a diff
Last edit: 25 Nov 2019 13:27 by scotty.sutherland.

Please Log in or Create an account to join the conversation.

More
25 Nov 2019 19:02 #35319 by Cheryl
Replied by Cheryl on topic Subaru Impreza 2003
Wondering if when the fan is supposed to kick on the pcm is bumping up the idle
The following user(s) said Thank You: scotty.sutherland

Please Log in or Create an account to join the conversation.

  • scotty.sutherland
  • scotty.sutherland's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
26 Nov 2019 00:42 #35326 by scotty.sutherland
Replied by scotty.sutherland on topic Subaru Impreza 2003
going to check it out today as was near enuff dark wen i went out yest ;)

Please Log in or Create an account to join the conversation.

  • scotty.sutherland
  • scotty.sutherland's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
27 Nov 2019 11:14 - 27 Nov 2019 13:01 #35377 by scotty.sutherland
Replied by scotty.sutherland on topic Subaru Impreza 2003
ok putting tht stock filter on.. thts made a HUGE diff idles at 750-800 now :D but idle is dropping loow after i clutch etc then goes bk up n idles nice , tripped a p1444 evap code (ive had evap etc off n checked it today so i figured thts wat caused tht code) cleaned iacv few days ago so tht is clean and spins smooth, ive had an idle issue like tht b4 but cant remember wat caused it :S
Last edit: 27 Nov 2019 13:01 by scotty.sutherland.

Please Log in or Create an account to join the conversation.

  • Noah
  • Noah's Avatar
  • Offline
  • Moderator
  • Moderator
  • Massachusetts, USA
More
27 Nov 2019 17:39 #35391 by Noah
Replied by Noah on topic Subaru Impreza 2003
Good thing that air cleaner didn't end up in the trash :)

Do you have a scanner that will show iac counter?
I might try cleaning the throttle body and then resetting the PCM, then idling and driving it to relearn.
Thinking you might just be at maximum idle air correction and there's just no room for the iac to increase air flow.

"Learn, apply, repeat."

Please Log in or Create an account to join the conversation.

  • scotty.sutherland
  • scotty.sutherland's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
28 Nov 2019 10:19 #35405 by scotty.sutherland
Replied by scotty.sutherland on topic Subaru Impreza 2003
the whole intake system is clean as its recent, throttle body, manifold, iacv, injectors etc :) it hates cold starts...idles really low n struggles like before for few mins then kinna surges high n is fine wen it gets warmed up a bit :S

Please Log in or Create an account to join the conversation.

  • scotty.sutherland
  • scotty.sutherland's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
28 Nov 2019 10:30 #35406 by scotty.sutherland
Replied by scotty.sutherland on topic Subaru Impreza 2003
this is only data mine shows, thts log from warmed up not got 1 from cold yet :)
Attachments:

Please Log in or Create an account to join the conversation.

  • Noah
  • Noah's Avatar
  • Offline
  • Moderator
  • Moderator
  • Massachusetts, USA
More
28 Nov 2019 11:00 - 28 Nov 2019 11:01 #35407 by Noah
Replied by Noah on topic Subaru Impreza 2003
Have a look at the coolant temp PID before you start it cold. See if it looks reasonable. It should be very near the intake air temperature or ambient air temperature.
During that capture you were 50°c min, max & avg. So it never changed during the capture which doesn't necessarily indicate a problem depending on how long it was running and how long you were logging.
(50°C × 9/5) + 32 = 122°F. Thanks Google :)

If you can make a custom data list I would include:
Engine RPM, Desired RPM, IAC position, ECT, IAT, whatever throttle position data you have and engine run time (if available) and watch it warm up a little from a cold start without giving it any throttle.

"Learn, apply, repeat."
Last edit: 28 Nov 2019 11:01 by Noah.
The following user(s) said Thank You: scotty.sutherland

Please Log in or Create an account to join the conversation.

  • scotty.sutherland
  • scotty.sutherland's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
28 Nov 2019 11:40 #35409 by scotty.sutherland
Replied by scotty.sutherland on topic Subaru Impreza 2003
yea i started logging once i realised it started idling fine so it was already kinna warm, ill go get a cold start with no throttle, i open the log in scanxl, i have a bluetooth obd there pretty basic lol

Please Log in or Create an account to join the conversation.

  • scotty.sutherland
  • scotty.sutherland's Avatar Topic Author
  • Offline
  • New Member
  • New Member
More
01 Dec 2019 16:12 - 01 Dec 2019 16:14 #35489 by scotty.sutherland
Replied by scotty.sutherland on topic Subaru Impreza 2003
**FIXED** Thanks again NOAH mate! it was only needing to relearn after tht going on as its been a good 90 miles and drives n idles spot on!!.. the last cold start was normal too for the first time lol only thing is tht evap code must need a new evap purge solenoid valve :whistle: B)

**thanks mr paul danner for sending me to the forum**
Last edit: 01 Dec 2019 16:14 by scotty.sutherland.
The following user(s) said Thank You: Noah

Please Log in or Create an account to join the conversation.

  • Noah
  • Noah's Avatar
  • Offline
  • Moderator
  • Moderator
  • Massachusetts, USA
More
02 Dec 2019 18:16 #35521 by Noah
Replied by Noah on topic Subaru Impreza 2003
Sweet, glad she's back to normal.

"Learn, apply, repeat."
The following user(s) said Thank You: scotty.sutherland

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.745 seconds