× Help us help you. By posting the year, make, model and engine near the beginning of your help request, followed by the symptoms (no start, high idle, misfire etc.) Along with any prevalent Diagnostic Trouble Codes, aka DTCs, other forum members will be able to help you get to a solution more quickly and easily!

LACK OF PICKUP--AGAIN

  • emo666
  • Topic Author
  • Offline
  • New Member
  • New Member
More
29 Sep 2019 11:17 #33914 by emo666
LACK OF PICKUP--AGAIN was created by emo666
BACK AGAIN--PROBLEM WITH 1989 FORD RANGER 2.9-- "OBD 1" DIAGNOSTIC SYSTEM. DOGS DOWN WHEN ACCELERATING--RUNS FINE -STARTS FINE- NO ENGINE LIGHT--NO CODES. REPLACED MAP SENSOR -- RAN GREAT FOR 2 WEEKS-- BUT SLOWLY REGRESSED BACK TO NOT ACCELERATING AND SHIFTING HARD. (AUTOMATIC). ONLY 92000 MILES --ALREADY REPLACED DISTRIBUTOR MODULE--MAP- FUEL PUMP PRESSURE GOOD. TOP SPEED 50 MPH .

Please Log in or Create an account to join the conversation.

  • Chad
  • Chad's Avatar
  • Offline
  • Moderator
  • Moderator
  • I am not a parts changer.
More
29 Sep 2019 11:44 #33915 by Chad
Replied by Chad on topic LACK OF PICKUP--AGAIN
Have you checked exhaust back-pressure?

"Knowledge is a weapon. Arm yourself, well, before going to do battle."
"Understanding a question is half an answer."

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.520 seconds