× Help us help you. By posting the year, make, model and engine near the beginning of your help request, followed by the symptoms (no start, high idle, misfire etc.) Along with any prevalent Diagnostic Trouble Codes, aka DTCs, other forum members will be able to help you get to a solution more quickly and easily!

2010 acadia engine in reduced power mode

More
15 Aug 2019 14:11 #32842 by vhehn
i have a 2010 acadia. it has check a engine light on and triangle light on. its flashing service stabilitrack and traction control and reduced power. it is currently in limp mode no acceleration. this car recently had a new timing chain installed. its showing codes p2119,p2101,p0221,p2176,p0100,p0113.
the codes point to a throttle body problem. so far i have replaced the throttle body with no change and the wiring tests ok. when you first turn the key on the throttle body responds to the acc pedal until the check lights go out on the dash. then the ecm seems to shut of the connection. can someone point me to where i should go next? i am suspecting an ecm.
here are some data points from my scanner app:
obd module voltage: 14.3

fuel system status: open loop due to engine load or fuel cut due to deceleration.

calculated engine load value; 100%

engine coolant temp: 210

short term fuel trim bank 1: 0% in neutral. -5.47 in drive if you put the car in drive you get a reading.

long term fuel trim bank 1: 0% 0%

short term fuel trim bank 2: 0% -3.91 in drive

long term fuel trim bank 2: 0% 0%

timing advance: -5-+3 bounces around

intake air temp: 89.6

maff air flow rate: 15.9 g/sec

throttle position: 32%

ox sensor1 bank 1 voltage: 0v in neutral. .74 in drive

ox sensor1 bank 1 stft: 0 in neutral -5.47 in drive

ox sensor bank2 bank 2 voltage: 0 in neutral. .6 in drive

ox sensor bank2 stft: nr nr

ox sensor1 bank2 voltage: 0 in neutral. .7 in drive

ox sensor1 bank2 stft:0 in neutral. -7.81 in drive

ox sensor2 bank2 voltage: 0 in neutral. .6 in drive

ox sensor2 bank2 stft: nr nr

fuel rail pressure: 503-639 bounces around

catalyst temp bank 1 sensor 1: 1468 (seems hi)

catalyst temp bank 2 sensor 1: 1401(seems hi)

control module voltage. 14.07

absolute load value: 47%

fuel air commanded ratio: 29.3%

relative throttle position: 18%

ambient air temp: 64.4

absolute throttle position b: 77%

absolute pedal position d: 19%

absolute pedal position e: 19%

commanded throttle actuator: 9%

long term secondary oxygen sensor trim bank 1: 0

long term secondary oxygen sensor trim bank 3:0

long term secondary oxygen sensor trim bank 2:0

long term secondary oxygen sensor trim bank 4:0

Please Log in or Create an account to join the conversation.

More
16 Aug 2019 10:17 #32858 by Ben
take a look at your pedal position % for all sensors with closed throttle and slowly open throttle to 100% and make sure they all agree all the time. it looks like your data shows a couple of them saying 18 or 19% and 1 saying 77%

Sent from my SM-N920P using Tapatalk

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.446 seconds