×
ScannerDanner Premium Customer Support (15 Mar 2019)

Please add This email address is being protected from spambots. You need JavaScript enabled to view it. as a contact in your email system. I am having a very hard time communicating with some of you because my reply messages are ending up in your spam folder! So please check your spam folders too!

× Help us help you. By posting the year, make, model and engine near the beginning of your help request, followed by the symptoms (no start, high idle, misfire etc.) Along with any prevalent Diagnostic Trouble Codes, aka DTCs, other forum members will be able to help you get to a solution more quickly and easily!

Extreme high idle

  • Deltron
  • Topic Author
  • Offline
  • Junior Member
  • Junior Member
More
31 Mar 2019 15:05 #28312 by Deltron
Extreme high idle was created by Deltron
Hey guys, got a good one here. One my service advisors has a 2002 saturn sl1 with the 1.9. He's experiencing a super high idle in any gear and it seems to settle down in park. Car will go 30+ mph on its own with no throttle. My "master tech" colleague shotgunned an IAC and that obviously didn't fix it. IAC steps during the problem can reach 120. Car has a -20 STFT and -3 LTFT, single wire O2 reads stoic at this level. Has a single code stored for coolant temp not reaching regulated temp, which it is not. Holding 3k this temp will only hit 160 max both with laser gun and scan data. Pulse width 5ms.

Is the high idle a result of the low temp? That's a dangerous strategy if so. Hard to believe it would allow trim correction of an intentional richening.

Please Log in or Create an account to join the conversation.

More
31 Mar 2019 15:21 - 31 Mar 2019 15:27 #28314 by guafa
Replied by guafa on topic Extreme high idle
Hi Deltron.

Is the system jumping to closed loop?

What is telling you MAP/MAF?
Last edit: 31 Mar 2019 15:27 by guafa.

Please Log in or Create an account to join the conversation.

  • Deltron
  • Topic Author
  • Offline
  • Junior Member
  • Junior Member
More
31 Mar 2019 15:26 - 31 Mar 2019 17:53 #28315 by Deltron
Replied by Deltron on topic Extreme high idle
Yes, it's reaching closed loop. Map activity is normal, no MAF.
Last edit: 31 Mar 2019 17:53 by Deltron.

Please Log in or Create an account to join the conversation.

  • Matts Auto
  • Away
  • Premium Member
  • Premium Member
More
31 Mar 2019 19:22 #28326 by Matts Auto
Replied by Matts Auto on topic Extreme high idle
I've encountered a number of vehicles with high idle from low coolant level or stuck open thermostat so I would say yes a low coolant temp could cause an idle issue

Please Log in or Create an account to join the conversation.

  • ScannerDanner
  • ScannerDanner's Avatar
  • Away
  • Administrator
  • Administrator
  • Religion says do, Jesus says done!
More
31 Mar 2019 19:49 #28328 by ScannerDanner
Replied by ScannerDanner on topic Extreme high idle
You said IAC counts are at 120 during the high idle? This means the PCM is commanding it and you most likely have an input issue.
Please report TPS readings KOEO and the running at idle.
It would be nice to have voltage and percentage numbers if possible.
Then look at you park/neutral switch, AC command and power steering psi inputs.
Also, what are your ECT readings compared to actual temp? Maybe you said that.
I'm not worried about the low temp, that's not causing your issue, you need a thermostat but I am worried about an inaccurate ECT, these are know for that.

Don't be a parts changer!

Please Log in or Create an account to join the conversation.

  • Deltron
  • Topic Author
  • Offline
  • Junior Member
  • Junior Member
More
11 Apr 2019 17:29 #28595 by Deltron
Replied by Deltron on topic Extreme high idle
Quick update, apparently on my day off after I posted this he decided to put a new PCV valve in, and according to him that fixed the problem.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.552 seconds