×
ScannerDanner Premium Customer Support (15 Mar 2019)

Please add This email address is being protected from spambots. You need JavaScript enabled to view it. as a contact in your email system. I am having a very hard time communicating with some of you because my reply messages are ending up in your spam folder! So please check your spam folders too!

× Help us help you. By posting the year, make, model and engine near the beginning of your help request, followed by the symptoms (no start, high idle, misfire etc.) Along with any prevalent Diagnostic Trouble Codes, aka DTCs, other forum members will be able to help you get to a solution more quickly and easily!

01 Caravan 3.3 P1698

  • Dothedew92
  • Topic Author
  • Offline
  • New Member
  • New Member
More
23 Feb 2019 19:49 #27310 by Dothedew92
01 Caravan 3.3 P1698 was created by Dothedew92
Hi,
I have a 01 caravan 3.3 auto that i had on ramps to fix coolant leak.
I ended up bypassing rear heater core. But we had a freeze -20. before i started it again.
When I started it (30 degrees air temp) the speedo went wacko and shifter indicator was all lit.
It died few times when i put it in reverse.
I drove it a block while it was trying to figure out what gear to be in until i parked it.
Next day it started up, speedo jumped then settled at 0.
Now speedo stays at zero. trans stuck in limp mode and drives.
I tested battery, wiggled wires. no corrosion at pcm. speed sensor wires look good.
Has code P1698 pcm is not receiving a bus message from the tcm.
erased code and it came back.
How do i test for broken wires. Bad module. Or is something else causing module to go quite.
I have multi meter and cheap basic scan tool. Can I test speedos resistance from tcm plug?
Schematics for tcm, ecm and any others i'll need.

Note air bag light is on, I don't know if it was before. I read somewhere that air bag module can disrupt bus signal. Can I just unplug module to test if tcm communicates again.

Please help. Thank You.

Please Log in or Create an account to join the conversation.

More
02 Mar 2019 17:33 #27524 by Rockyroad
Replied by Rockyroad on topic 01 Caravan 3.3 P1698
Those vans....those vans...it wouldn’t be polite to say what I want here. My neighbors have two, 01’ 03’. I changed a abs sensor on the 03’ and it whacked the tranny out. You have to go in the tcm with a scan tool and do reset procedure. It’s pretty simple but does need a tool. I’m not aware of another way. My old otc genisys handled it no problem.

Someday I'll figure this out

Please Log in or Create an account to join the conversation.

More
02 Mar 2019 17:38 #27525 by Rockyroad
Replied by Rockyroad on topic 01 Caravan 3.3 P1698
There’s also the possibility that little silver box on the front of the fuse box has some corrosion. If you have other whacky electrical gremlins take that box apart and clean well

Someday I'll figure this out

Please Log in or Create an account to join the conversation.

More
06 Mar 2019 21:06 #27639 by wacoeagle
Replied by wacoeagle on topic 01 Caravan 3.3 P1698
its amazing that they hold thier value, never figured that out. wife wants one, but im not wanting to get into the world of electrical hell.

Please Log in or Create an account to join the conversation.

More
07 Mar 2019 13:14 #27645 by wacoeagle
Replied by wacoeagle on topic 01 Caravan 3.3 P1698
I believe theres also a module box behind the front fender well cover, they corrode badly as well, especially in the salt belt of the US.

Please Log in or Create an account to join the conversation.

More
07 Mar 2019 15:31 #27646 by chief eaglebear
Replied by chief eaglebear on topic 01 Caravan 3.3 P1698
I woukld confirm powers and grounds on both modules first and then if problem persists maybe scope bus or check resistance in dlc

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.551 seconds