×
May 29-30th 2020 event at Rosedale Tech has been moved to April 30–May 1, 2021 (29 Apr 2020)

Full refunds will be given unless you want us to hold your spot for next year. Hope to see you there!
www.rosedaletech.org/diagnostics-seminar...aGdvxG1mVYe2wjxQ0mYw

Picoscope 4425 advanced-kit

  • kostelectronics
  • Topic Author
  • Offline
  • Senior Member
  • Senior Member
More
15 Feb 2018 06:35 #17923 by kostelectronics
Picoscope 4425 advanced-kit was created by kostelectronics
Hi everyone!

I've bought a Picoscope advanced kit and played around to learn how to use this Instrument.

I've tryed to measure the starter-current on my own car with the 2000A Amp-Current-Clamp from the kit.
As soon i degauss (Zero) the Amp-Clamp, i got an error, that the current is out of range (too high).
Also i get this error when i measure the starter-current and the waveform is way out on my Screen.

I selected the "2000A Amp-Clamp" in the Software and set the range up to 1000A.

Do i Need to configure the Amp-Clamp in the Software before?

BR Matthias

Please Log in or Create an account to join the conversation.

  • Andy.MacFadyen
  • Andy.MacFadyen's Avatar
  • Away
  • Moderator
  • Moderator
More
15 Feb 2018 11:09 #17934 by Andy.MacFadyen
Replied by Andy.MacFadyen on topic Picoscope 4425 advanced-kit
Sounds like you might have a bad clamp as a sanity test have you got a way to connect the BNC to a digital voltmeter ?

" We're trying to plug a hole in the universe, what are you doing ?. "
(Walter Bishop Fringe TV show)



Please Log in or Create an account to join the conversation.

  • graywave
  • graywave's Avatar
  • Offline
  • Elite Member
  • Elite Member
  • Adv. Diagnostics New Hampshire
More
03 Mar 2018 09:52 - 03 Mar 2018 09:54 #18490 by graywave
Replied by graywave on topic Picoscope 4425 advanced-kit
Did you zero the clamp off the wires? I don't think that should matter

Confirm what it's not, and fix what it is!
Last edit: 03 Mar 2018 09:54 by graywave.
The following user(s) said Thank You: kostelectronics

Please Log in or Create an account to join the conversation.

  • kostelectronics
  • Topic Author
  • Offline
  • Senior Member
  • Senior Member
More
03 Mar 2018 17:31 #18525 by kostelectronics
Replied by kostelectronics on topic Picoscope 4425 advanced-kit
yes i did. but i realized that this peak is pretty normal, the inside electronics of the clamp cause a very high spike when i degauss the probe. i didn't know this before.

BR Matthias

Please Log in or Create an account to join the conversation.

More
11 Oct 2019 16:02 #34186 by robert.lesaca
Replied by robert.lesaca on topic Picoscope 4425 advanced-kit
Did you specifically mention/select in the CH that you are in that you are using the 1000 Amp probe?

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Time to create page: 0.278 seconds